Crash in Oasys software


We have recently upgraded from Windows 7 to Windows 10 on one of our computers. I installed the february 2020 version of Oasys. When we select the PEF measurement device, ASMA1, the application crashes. We have tried to open the program before turning on the device and the other way around.

Error: OAutil.exe: EAccessViolation (Bug F33B4AF7; v1.7.7348.30067)

Part of the crash log says this:
“ 2.1 Date : Tue, 9 Feb 2021 09:27:59 +0100
2.2 Address : 00BF2765
2.3 Module Name : OAutil.exe
2.4 Module Version: 1.7.7348.30067
2.5 Type : EAccessViolation
2.6 Message : Access violation at address 00BF2765 in module 'OAutil.exe'. Read of address 00000048.
2.7 ID : F33B4AF7”

I've tried to reinstall the program once. Any clues how we can fix this?
Occupational Asthma, Worker, 2/9/2021, 2/17/2021,


we will take a look at this issue. in the meantime, do you have an option to select vitalograph diary? If so, try that in the meantime and see if that works ok.


Hi Vicky, thanks for following up.

We selected diary and got the error "Access violation 00BF2765 in module "OAutil.exe" Read of address 00000048.

Regards Eivind

Hi, we have found out the problem with the Asma 1 meter.

Unfortunately the third party thing we use to talk to the meter no longer works with the current version of the software (which gets updated to use the latest version of other things every so often). At the moment it isn't feasible to fix this, although it might become so in the future, or we might do things a different way (in most cases, people export the data from the meter, and then Oasys reads this in, which is more robust to these sorts of problems).

We've looked at the history of the code, and the problem was introduced after the June 2019 release (it looks like not many people use the Asma 1 feature), so I think it you install this release it should work.

Please let us know how you get on.
Oasys June 2019

Thanks a lot, we will try the download in the link. Regards Eivind Hagen, St. Olavs HF

Is there any specific firewall openings that has to be made?
I saw this was blocked UDP://
Not sure if it's related to this.

Hi, The June 2019 version solved our problems! I am happy and the user is very happy.
Thank you so much for excellent support! Regards, Eivind Hagen, St. Olavs HF.

Please sign in or register to add your thoughts.

Oasys and occupational asthma smoke logo